Google+

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[1.6.x] Sistem de Limbă Română
#1
Nume modificare : Sistem de Limbă Română
Versiune : 2.2
Distribuit de : MyBB România
Dezvoltare : https://github.com/Mihu90/SLR (Maris Ovidiu, Ungureanu Radu - traducători ; Surdeanu Mihai - dezvoltator)

Descriere
Modificarea ‘‘Sistem de Limbă Română’’ are rolul de a administra traducerile de limbă română de pe forumul tău MyBB. Mai mult decât atât îţi oferă posibilitatea de a adăuga sau de a şterge foarte uşor legătura către noi din cadrul subsolul paginii de index a forumului tău.
Instalare
Pentru instalarea modificării urmaţi paşii de mai jos:
1.Încarcă conţinutul directorului admin/modules/rolang din arhivă pe serverul tău, exact în aceeaşi locaţie.
2.Încarcă conţinutul directorului images/rolang din arhivă pe serverul tău, exact în aceeaşi locaţie.
3.Încarcă conţinutul directorului inc din arhivă pe serverul tău, exact în aceeaşi locaţie.
4.Încarcă conţinutul directorului inc/plugins din arhivă pe serverul tău, exact în aceeaşi locaţie.
5.Du-te la pagina Admin CP > Plugin Manager > Sistemul de Limbă Română şi activează modificarea.
6.Configurează modificarea! Acest lucru poate fi realizat de pe pagina de la adresa Admin CP > Board settings > Change Settings > Sistemul de Limbă Română.
7.Administrează modificarea! Acest lucru poate fi realizat de pe pagina de la adresa Admin CP >  SLR.
8.Bucură-te de pluginTongue
Utilizare
Pentru a afla detaliile legate de modul de utilizare al acestei modificări vă invităm să citiţi cele 8 pagini din fişierul ReadMe.pdf din arhiva ataşată în cadrul acestui subiect.
Mulţumiri
Ţin să mulţumesc pe această cale tuturor celor care au participat la realizarea acestui proiect. Sperăm ca munca depusă de noi să se reflecte în calitatea serviciilor oferite şi în mulţumirile primite de la alţi utilizatori.
Tutorial de utilizare video (pentru versiunea 2.1)


Descarcă
.zip   SLR v2.2 MyBB.ro.zip (Size: 358.14 KB / Downloads: 156)
.zip   SLR v2.1 MyBB.ro.zip (Size: 299.36 KB / Downloads: 29)
.zip   SLR v2.0 MyBB.ro.zip (Size: 268.94 KB / Downloads: 17)
Licenţă
Licenţa de distribuire a acestei modificări se găseşţe în cadrul fişierului License.pdf din arhivă. Citiţi-o cu atenţie înainte de a utiliza modificarea şi traducerile aferente!
Dezvoltare
Pentru a raporta diverse buguri sau pentru a fi la curent cu eventualele actualizări ale modificării vă rugăm să verificaţi pagina de aici. Vă mulţumim pentru înţelegere!
Probleme ce pot apărea la utilizare
1.Pe forum nu sunt afişate imaginile pachetului de limbă
Această problemă apare deoarece utilizaţi pe forum dvs. mai multe teme, iar unele dintre ele au directoarele de imagine diferite ca structură faţă de cea default de la MyBB. Pentru rezolvarea problemei va trebui să copiaţi directoarele romanian şi groupimages/romanian din folderul images de pe server în folderul specific temei pe care o utilizaţi pe forum, păstrând structura internă a fiecărui folder. Începând cu versiunea 2.1, acest lucru se poate face şi automat cu ajutorul tabelului intitulat ‘‘Setul de imagini ale traducerii’’ de pe pagina de ‘‘Actualizări’’.
2.La verificarea unor posibile actualizări primesc eroare, chiar dacă serverul funcţionează!
Dacă la apăsarea butonului de verificare a unor posibile actualizări primiţi eroare, chiar dacă ştiţi sigur că serverul de date funcţionează corect atunci se poate să nu aveţi legătura către noi din subsol. Pentru rezolvarea problemei va trebui să adăugaţi o legătură către noi în cadrul subsolului forumului dvs., folosind butonul specific de pe pagina : Admin CP > SLR > Informaţii.
3.La instalarea unei actualizări primesc eroarea "eroare:ext". Ce fac?
Asta înseamnă că pe serverul tău există deja o arhivă cu acelaţi nume cu cea care trebuie descărcată de către modificare. Pentru rezolvarea problemei şi a erorii va trebui să verificaţi şi să ştergeţi orice arhivă care începe cu ro_ atât din directorul inc/languages cât şi din images. După ce le ştergeţi atunci veţi putea da un refresh şi veţi putea realiza actualizarea.
4.Ce fac dacă la actualizare primesc eroarea : "eroare:zip"?
Eroare te anunţă că procesul de dezarhivare a fişierului descărcat nu s-a putut realiza. Eroarea apare din mai multe motive : fie directorul de lucru nu are permisiuni de scriere, fie arhiva nu are un format corect, nu este de tip zip, fie este coruptă. Dacă vă apare această eroare atunci vă rugăm să ne contactaţi pentru a vedea exact de unde provine eroarea şi cum puteţi să o rezolvaţi!
5.Procesul de actualizare a unei versiuni de limbă întâmpină eroarea "eroare:del". Cum scap de ea?
După ce descarcă arhiva cu pachetul de limbă şi o dezarhivează pe serverul tău, modificarea trebuie să şteargă această arhivă pentru a nu încărca aiurea serverul cu informaţii. Dacă acţiunea de ştergere a arhivei nu are loc cu succes, atunci întâmpinaţi această eroare. Rezolvarea este foarte simplă : ştergeţi eventualele arhive care încep cu ro_ din cadrul directoarelor images şi inc/languages. Chiar dacă va apărut această eroare atunci trebuie să ştiţi că se poate ca procesul de actualizare să fi avut loc, numai că ultimul pas, ştergerea fişierului descărcat nu a putut fi şters!
Users : collective term for those who use computers. Users are divided into three types : novice, intermediate and expert.
Novice users : people who are afraid that simply pressing a key might break their computer.
Intermediate users : people who don`t know how to fix their computer after they`ve just pressed a key that broke it.
Expert users : people who break other people`s computers.
#2
Fatal error: Class 'ZipArchive' not found in /home/www/static/WEBSITE/LINKWEBSITE/public_html/forum/admin/modules/rolang/updates.php on line 127
Ce fac?
#3
Salut!
În primul rând trebuie să ai versiunea PHP 5.2, cel puţin. Doi la mână, dacă ai o versiune mai mare de 5.2 atunci se poate ca pachetul să nu fi fost compilat cu clasa zip.
Poţi verifica asta rulând următoarea comandă într-un mediu Linux :

Code:
/usr/local/bin/php -i | grep conf

Dacă --with-zip nu se găseşte în cadrul rezultatului atunci nu este compilat cu acest pachet. oricum va trebui să îi contactezi pe cei de la host. Fără posibilitatea extragerii arhivelor nu se poate utiliza această modificare.
PS : Voi încerca pe viitor să fac o modificare care să fie compatibilă şi să încerc să evit această problemă.
Edit : Cerinţele pentru extragerea arhivei sunt PHP 5 >= 5.2.0, PECL zip >= 1.1.0.

Users : collective term for those who use computers. Users are divided into three types : novice, intermediate and expert.
Novice users : people who are afraid that simply pressing a key might break their computer.
Intermediate users : people who don`t know how to fix their computer after they`ve just pressed a key that broke it.
Expert users : people who break other people`s computers.
#4
M-am gândit să fac în aşa fel încât să funcţioneze şi fără această clasă ZipArchive. Versiunea 2.1 va apărea la data de 15 august 2011.
Users : collective term for those who use computers. Users are divided into three types : novice, intermediate and expert.
Novice users : people who are afraid that simply pressing a key might break their computer.
Intermediate users : people who don`t know how to fix their computer after they`ve just pressed a key that broke it.
Expert users : people who break other people`s computers.
#5
PHP Version 5.3.5-pl0-gentoo
#6
Atunci nu ai pachetul PECL zip compilat. Oricum ţin să te anunţ că problema a fost rezolvată şi pe data de 15 august se va publica o versiune ce cuprinde şi o altă metodă de dezarhivare, care să meargă pentru toate serverele. Ai puţină răbdare până atunci!
Users : collective term for those who use computers. Users are divided into three types : novice, intermediate and expert.
Novice users : people who are afraid that simply pressing a key might break their computer.
Intermediate users : people who don`t know how to fix their computer after they`ve just pressed a key that broke it.
Expert users : people who break other people`s computers.
#7
Sa speram ca va fii folositor pentru toata lumea, sper sa fie folosit, si munca depusa sa nu fie in zadar. Bravo pentru treaba asta.
Keep walking !   http://www.mybb.ro
#8
Fatal error: Class 'ZipArchive' not found in /home/paladin/public_html/admin/modules/rolang/updates.php on line 127

Asta mi-a aparut prima oara,acum imi zice eroare:ext - deci Pachetul dorit există deja pe server.
Mie imi zice ca versiunea curenta de limba romana este 1603 dar nu pot instala 1604,ce sa fac? Aveam inainte V 1.0 de la traducere dar doar am dezactivato,trebuie sa o sterg? Multumesc.
#9
Salut. Acum am făcut un fix pentru prima problemă. Nu îți va mai apărea această eroare de Class not found... Doi la mână, va trebui să ștergi de pe server arhiva din directorul inc/languages si images daca exista una. Pentru ca la tine scriptul a descarcat arhiva de pe serverul nostru dar la dezarhivarea ei a aparut o eroare si a ramas in acel director nestearsa! Pur si simplu stergi arhiva, faci update la versiunea 2.1, vezi ca exista si un fisier nou, o clasa care trebuie urcata pe server si apoi reincerci apasand pe butonul de verificare.
Nu e neaparat nevoie sa stergi traducerea ce o aveai pentru versiunea 1.0. Noua versiune va suprascrie datele.
Users : collective term for those who use computers. Users are divided into three types : novice, intermediate and expert.
Novice users : people who are afraid that simply pressing a key might break their computer.
Intermediate users : people who don`t know how to fix their computer after they`ve just pressed a key that broke it.
Expert users : people who break other people`s computers.
#10
Versiune 2.2 va apărea în jurul datei de 1 octombrie 2011. Ea va aduce multe modificări.
- La descărcarea arhivelor de pe server se va impune o limită, astfel încât viteza de descărcare să fie mai mică decât cea de acum și în cazul unei suprasolicitări a server-ului să se evite posibilitatea ca acesta să nu se mai încarce pentru userii normali.
- Versiunea va beneficia și de un sistem de jurnalizare (log-uri) unde veți putea vedea diverse erori sau mesaje ce apar pe parcursul utilizării modificării. De asemenea se va rescrie funcția de realizare a unei actualizări de traducere utilizând try and catch, astfel încât la apariția unei erori se va verifica dacă nu cumva arhivele descărcate există pe server!
- Mai mult decât atât lucrăm la o pagină se statistici. Din păcate nu vă pot da prea multe detalii pentru că aici nu e pus totul la punct.
- Pe lângă partea de client va apărea și partea de administrare (server) pentru această modificare. Adică va exista o secțiune în care se vor putea adăuga versiuni, edita sau vizualiza statistici avansate legate de cei care utilizează traducerile noastre.
- Ca și tehnologii ne-am gândit că ar fi mai bine să folosim cât mai mult Ajax, astfel încât să nu existe probleme legate de încărcarea datelor. Adică paginii să nu îi ia foarte mult timp până să se încarce.
Mai multe detalii vor apărea pe parcurs. Dacă aveți păreri, sugestii legate de această modificare o puteți face până la data de 15 septembrie 2011.
Users : collective term for those who use computers. Users are divided into three types : novice, intermediate and expert.
Novice users : people who are afraid that simply pressing a key might break their computer.
Intermediate users : people who don`t know how to fix their computer after they`ve just pressed a key that broke it.
Expert users : people who break other people`s computers.


Forum Jump:


Users browsing this thread: 1 Guest(s)