Google+

Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Rezolvat Redirectare gresita, lipsa bara format si lipsa diacritice in mail
#1
Salut,

De curand am dat drumul formului meu, este vorba despre http://www.espressoman.ro/forum/ si intampin trei probleme, pentru care va cer ajutorul:

1. Daca utilizatorul (nelogat) este pe un topic anume si vrea sa raspunda, dupa logarea ceruta de forum, va fi redirectionat catre prima pagina nu catre topicul pe care se afla. Cum pot face ca dupa logare, utilizatorul sa se intoarca automat acolo unde era?

2. Atunci cand scriu un post nou nu imi apare bara de formatare cu bold, italic, hyperlink etc. Aici pe forum o vad. La mine nu reusesc in niciun fel sa o aduc. Am doar iconitele pentru post si sub ele direct casuta pentru text. Acelasi lucru as vrea sa se intample si in formularul de "Raspuns rapid".

3. Cand primesc un mail de la forum legat de un mesaj nou, in loc de "Raspuns nou la" imi afiseaza "Răspuns nou la". Probabil e din cauza diacriticelor caci se intampla pe doua browsere diferite.

P.S. As vrea sa adaug copyright-ul pentru traducere dar nu stiu cum. Poate ma ajutati cu un link legat de procedura pas cu pas.

Multumesc,
#2
Salut.

La Problema 1 si 2 este doar din cauza temei din cate cred eu, motivul fiind faptul ca acel redirect il face mybb-ul atuomat catre topic, iar acele imaginii ar trebui sa-ti apara (problema intalnita si la alte teme care nu sunt pe aceasi versiune de mybb, deci nu de fiecare data cu succes peste Ignore version). Astfel spus, ti-as sugera sa renunti la tema aia sau sa umbli prima data prin post bit,dar e putin cam mult de lucru).

Ti-as sugera o tema de pe Mybb.com sau daca e sa rogi pe cineva sa-ti faca niste modificari pe ceea default, e mai ok asa si arata mai bine forumul.

Cat despre problema 3, nu am inteles de fel. Adica iti da Raspuns nou la si problema ta e de ce o da cu diacritice sau alte genuri ? Explica te rog ceva mai bine ca sa inteleg si eu..

Legat de link-ul pentru Traducere, parca sistemul SLR are implementat o adaugare automata a link-ului in footer-ul forumului, dar chiar daca nu-l adaugi automat e doar un simplu link spre mybb.ro in footer, deci nu e mare lucru sa-l adaugi.
Keep walking !   http://www.mybb.ro
#3
Merci,
Tema este de pe mybb.com, Novus Tiger fiind destul de populara. Am mai schimbat eu doar unele culori, atat. Cica faza cu redirectarea spre index dupa logare ar fi un bug cunoscut - http://dev.mybb.com/issues/1667 Am incercat solutiile de acolo dar nu rezolva nimic.

Legat de problema 3, forumul vostru a tradus in diacritice ceea ce am scris eu in litere Smile Atasez un crop. Era vorba de un cod de caractere in locul diacriticelor. Vad ca se intampla inclusiv in mesajele primite de la mybb.ro nu numai de la forumul meu:
[Image: diacritice.jpg]
Se poate rezolva cumva sau este de la yahoo?
#4
1. Daca inlocuiesti fisierul functions.php cu acesta, ar trebui ca problema ta sa fie rezolvata.
2. Cred cas e o problema de Javascript. Totusi as dori un screenshot la bara de editare. La formularul de raspuns rapid, MyBB nu vine implicit cu editor, dar ii poti adauga unul prin intermediul unui plugin. Nu mai stiu cum se numea, dar exista sigur pe saitul oficial.
3. Varianta de traducere, e cu diacritice, pentru ca asa e si limba romana... Cateodata, mai ales in zonele in care se afiseaza mesaje prin intermediul unor coduri javascript, mesajele cu diacritice sunt afisate aiurea, deoarece nu se realizeaza conversia diacriticelor. Din pacate problema nu se poate rezolva decat prin eliminarea diacriticelor din acel text. Deci problema ar fi ca in loc de ă iti afiseaza ceva de genul : & # 2 5 9 ; (fara spatii) ?
4. Utilizezi traducerea si cu modificarea Sistem de Limba Romana? Daca utilizezi cu modificarea, atunci copyright-ul ar fi trebuit sa se adauge automat, altfel poti intra in Templates & Styles : Templates : Tema curenta : Footer Templates: footer si imediat dupa linia :

HTML Code
{$lang->powered_by} <a href="http://mybb.com/" target="_blank">MyBB{$mybbversion}</a>, &copy; 2002-{$copy_year} <a href="http://mybb.com/" target="_blank">MyBB Group</a>

sa adaugi ceva de acest gen :

HTML Code
Traducere : <a href="http://www.mybb.ro" target="_blank" alt="Traducere MyBB Romania">MyBB Romania</a>

Daca mai ai si alte intrebari nu ezita sa ni le pui. Mult succes.

Users : collective term for those who use computers. Users are divided into three types : novice, intermediate and expert.
Novice users : people who are afraid that simply pressing a key might break their computer.
Intermediate users : people who don`t know how to fix their computer after they`ve just pressed a key that broke it.
Expert users : people who break other people`s computers.
#5
Multumesc,
1. Nu are niciun efect. Tot in index ma baga! Si nu sunt singurul cu aceasta problema pe mybb.com
2. Sa spunem ca in Raspuns rapid nu e grav. Dar macar in Raspuns normal sa apara. Acum, cine nu stie html, nu poate adaug aun link pe un cuvant. Mi se pare grotesc sa impanzesc forumul cu link-uri intregi...
Un crop aici:
[Image: formate.jpg]

3. Dar nu se poate umbla undeva in fisierul care gestioneaza aceste texte si sa modific exact partea de text "Raspuns nou la", eliminand diacriticile doar pentru aceasta situatie, si punand un text normal?

4. Sincer, nu mai stiu exact ce traducere utilizez. Cred ca am luat link-ul din headerul acestui forum! O sa pun acea linie.
5. Ca si probleme adiacente, as mai avea recunoasterea deficitara a unor butoane in IE9. Aveti mai jos un versus intre ce vede Opera/Firefox (sunt multumit) si ce vede IE9 (niste x-uri aiurea unde nu este nimic de fapt):
[Image: paralel.jpg]

6. Si mai remarc faptul ca inline moderation un merge. Practic nu pot muta un topic dintr-o arie in alta arie! Poate daca incerc plugin-ul Move Post, de care nu m-am legat momentan!
#6
1. Citeşte aici şi aici.

2. Această problemă poate fi cauzată de diverse lucruri. Încearcă să adaugi în şablonul headerinclude următoarea linie:

Code:
<script type="text/javascript">jQuery.noConflict();</script>


3. Toate modificările la traducere pot fi făcute din AdminCP->Configuration->Languages->Română->Options->Edit Language Variables.

4. Observ că deja ai adăugat link-ul traducerii în subsol.

5. Problema e cauzată de faptul că ai menţionat adresa imaginii în şabloane, deşi imaginea nu există. De aceea în Firefox/Opera/Chrome imaginea este invizibilă (deoarece nu există), în timp ce în IE aceasta apare sub forma de pătrat cu un X în interior. Poţi rezolva problema dacă ştergi adresa imaginii din şabloane. De exemplu, pentru a şterge imaginea de la UserCP, trebuie să intri în şablonul header_welcomeblock_member şi să ştergi linia aceasta (poate să difere):

Code:
<img src="{$theme['imgdir']}/cplinks/usercp.png" alt="" title="" />

Repetă această acţiune până nu mai este nici o adresă a unei imagini specificate, dar care nu există.

6. Deci nu poţi muta nici un subiect? Primeşti o eroare sau nu se întâmplă nimic?

#7
2 si 6 sunt in proportie de 90% cauzate de aceeasi problema. Si sigur e ceva de Javascript. Poti pune aici continutul sablonului headerinclude din Ungrouped Templates?
Users : collective term for those who use computers. Users are divided into three types : novice, intermediate and expert.
Novice users : people who are afraid that simply pressing a key might break their computer.
Intermediate users : people who don`t know how to fix their computer after they`ve just pressed a key that broke it.
Expert users : people who break other people`s computers.
#8
Merci de implicare,

1. M-a bufnit rasul mai devreme cand eram pe subiectul acesta, apoi m-am dus sus sa ma logez ca sa pot raspunde si forumul vostru m-a trimis in index, in loc sa ma dea exact in pagina asta Smile E ceva asemanator cu ce am eu ca si problema. In alta ordine de idei stiam de cele doua link-uri insa, dupa cum se vede, in primul dintre ele se precizeaza "Unsolved Still", al doilea fiind de fapt solutia sugerata de Mihu, in prima sa postare aici. Mai precis, nu functioneaza!

2. Baltzatu, mai exact unde sa adaug acea linie? Ma refer ca si pozitionare in pagina, caci nu cred ca pot sa-i dau paste oriunde, fara sa tin cont de celelalte coduri...
Mihu - continutul sablonului e acesta.

3. Rezolvat! Merci.

4. Rezolvat! Merci.

5. Rezolvat! Merci.

6. Daca as dori sa-l mut, ar trebui sa bifez patratica din fata topicului, moment in care butonul "Du-te(0)" cred ca ar trebui sa se transforme in "Du-te(1)", iar din optiunile aflate in campul "Moderare în interiorul subiectelor" asa alege optiunea care ma interseaza. Problema constata si de multi altii pe forumul mybb.com este ca acel numar "0" din fata lui "Du-te" nu se schimba in 1, 2, 3 etc, indiferent cate topicuri as selecta. Deci varianta a doua Baltzatu, nu se intampla nimic..
#9
M-am deloc am intrat pe acest subiect şi după ce am apăsat pe răspunde şi m-am logat, m-a redirecţionat pe pagina care trebuia. Ideea e că în versiunea 1.6.7 această problemă a fost marcată ca şi rezolvată.
Încearcă să scoţi linia următoare :

HTML Code
<script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js"></script>

Mai mult decât atât în loc de :

HTML Code
<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/prototype.js?ver=1600"></script>
<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/general.js?ver=1600"></script>

pune, te rog :

HTML Code
<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/prototype.js?ver=1603"></script>
<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/general.js?ver=1603"></script>

Spune-mi dacă acum merge faza cu inline moderation? (Se poate să îţi dea peste cap alte modificări, nu contează, doar spune-mi dacă fără merge!)

Users : collective term for those who use computers. Users are divided into three types : novice, intermediate and expert.
Novice users : people who are afraid that simply pressing a key might break their computer.
Intermediate users : people who don`t know how to fix their computer after they`ve just pressed a key that broke it.
Expert users : people who break other people`s computers.
#10
(04-10-2012, 01:54 AM)Lyvyoo Wrote: 2. Atunci cand scriu un post nou nu imi apare bara de formatare cu bold, italic, hyperlink etc. Aici pe forum o vad. La mine nu reusesc in niciun fel sa o aduc. Am doar iconitele pentru post si sub ele direct casuta pentru text.

Problema asta o am si eu la o tema descarcata de pe net, cum as putea sa o rezolv ?


Forum Jump:


Users browsing this thread: 1 Guest(s)